{"action":"Upgrade pipenv to 2022.1.8 or later.","affected":[{"fixed":"2022.1.8","introduced":"2018.10.9"}],"component":"pipenv","cve_ids":["CVE-2022-21668"],"ecosystem":"PyPI","epss":0.03807,"exploited":false,"fixed_versions":["2022.1.8"],"ghsa_id":"GHSA-qc9x-gjcv-465w","id":"tcs_01M5KGJ18F44QPJCX5PPJ9WBK4","modified_at":"2023-11-08T04:08:06.997974Z","published_at":"2022-01-10T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-6","https://github.com/pypa/pipenv/releases/tag/v2022.1.8","https://github.com/pypa/pipenv/security/advisories/GHSA-qc9x-gjcv-465w","https://github.com/pypa/pipenv/commit/439782a8ae36c4762c88e43d5f0d8e563371b46f"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-6","url":"https://osv.dev/vulnerability/PYSEC-2022-6"}],"summary":"pipenv is a Python development workflow tool. Starting with version 2018.10.9 and prior to version 2022.1.8, a flaw in pipenv's parsing of requirements files allows an attacker to insert a specially c"}