{"action":"Upgrade tensorflow-cpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2022-23560"],"ecosystem":"PyPI","epss":0.00844,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-4hvf-hxvg-f67v","id":"tcs_01M5KGJ2RJ30RWH39T74T6RXFG","modified_at":"2026-07-13T16:43:48.812713857Z","published_at":"2022-02-04T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-69","https://github.com/tensorflow/tensorflow/commit/6364463d6f5b6254cac3d6aedf999b6a96225038","https://github.com/tensorflow/tensorflow/blob/ca6f96b62ad84207fbec580404eaa7dd7403a550/tensorflow/lite/kernels/internal/utils/sparsity_format_converter.cc#L252-L293","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4hvf-hxvg-f67v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-69","url":"https://osv.dev/vulnerability/PYSEC-2022-69"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. An attacker can craft a TFLite model that would allow limited reads and writes outside of arrays in TFLite. This exploits missing validation in"}