{"action":"Upgrade tensorflow-cpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2022-23568"],"ecosystem":"PyPI","epss":0.00807,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-6445-fm66-fvq2","id":"tcs_01M5KGJ4HJVNTRZ3FS4R696TMZ","modified_at":"2026-07-13T16:42:32.091992149Z","published_at":"2022-02-03T12:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-77","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/sparse_tensors_map_ops.cc","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6445-fm66-fvq2","https://github.com/tensorflow/tensorflow/commit/b51b82fe65ebace4475e3c54eb089c18a4403f1c","https://github.com/tensorflow/tensorflow/commit/a68f68061e263a88321c104a6c911fe5598050a8"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-77","url":"https://osv.dev/vulnerability/PYSEC-2022-77"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `AddManySparseToTensorsMap` is vulnerable to an integer overflow which results in a `CHECK`-fail when building new `Tenso"}