{"action":"Upgrade langchain to 0.0.247 or later.","affected":[{"fixed":"0.0.247","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-36188"],"ecosystem":"PyPI","epss":0.01895,"exploited":false,"fixed_versions":["0.0.247"],"ghsa_id":"GHSA-57fc-8q82-gfp3","id":"tcs_01M5KGJA8DTYMDCHX21Q7Q16E7","modified_at":"2026-06-10T17:01:09.326674805Z","published_at":"2023-07-06T14:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-109","https://github.com/langchain-ai/langchain/issues/5872","https://github.com/langchain-ai/langchain/pull/8425","https://github.com/advisories/GHSA-57fc-8q82-gfp3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-109","url":"https://osv.dev/vulnerability/PYSEC-2023-109"}],"summary":"An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method."}