{"action":"Upgrade apache-airflow to 2.6.3 or later.","affected":[{"fixed":"2.6.3","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2023-35908"],"ecosystem":"PyPI","epss":0.01026,"exploited":false,"fixed_versions":["2.6.3"],"ghsa_id":"GHSA-2h84-3crq-vgfj","id":"tcs_01M5KGJC9WZ7XBAPJ3509ZH3W6","modified_at":"2026-06-10T17:00:22.072323999Z","published_at":"2023-07-12T10:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-119","https://github.com/apache/airflow/pull/32014","https://lists.apache.org/thread/vsflptk5dt30vrfggn96nx87d7zr6yvw","https://github.com/advisories/GHSA-2h84-3crq-vgfj"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-119","url":"https://osv.dev/vulnerability/PYSEC-2023-119"}],"summary":"Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows unauthorized read access to a DAG through the URL. It is recommended to upgrade to a version that is not affected"}