{"action":"Upgrade langchain to 0.0.236 or later.","affected":[{"fixed":"0.0.236","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-36095"],"ecosystem":"PyPI","epss":0.0117,"exploited":false,"fixed_versions":["0.0.236"],"ghsa_id":"GHSA-gwqq-6vq7-5j86","id":"tcs_01M5KGJFTJVS0CAJC462GTR10M","modified_at":"2026-06-10T17:01:59.374667036Z","published_at":"2023-08-05T03:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-138","https://github.com/hwchase17/langchain","http://langchain.com","https://github.com/langchain-ai/langchain/issues/5872","https://github.com/advisories/GHSA-gwqq-6vq7-5j86"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-138","url":"https://osv.dev/vulnerability/PYSEC-2023-138"}],"summary":"An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain, affected functions include from_math_prompt and from_colored_obje"}