{"action":"Upgrade langchain to 0.0.247 or later.","affected":[{"fixed":"0.0.247","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-38860"],"ecosystem":"PyPI","epss":0.01417,"exploited":false,"fixed_versions":["0.0.247"],"ghsa_id":"GHSA-fj32-q626-pjjc","id":"tcs_01M5KGJH08D9V2CQSZKMQVD84M","modified_at":"2026-06-10T17:01:59.588223152Z","published_at":"2023-08-15T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-145","https://github.com/langchain-ai/langchain/issues/7641","https://github.com/advisories/GHSA-fj32-q626-pjjc"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-145","url":"https://osv.dev/vulnerability/PYSEC-2023-145"}],"summary":"An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter."}