{"action":"Upgrade langchain to 0.0.195 or later.","affected":[{"fixed":"0.0.195","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-38896"],"ecosystem":"PyPI","epss":0.01838,"exploited":false,"fixed_versions":["0.0.195"],"ghsa_id":"GHSA-92j5-3459-qgp4","id":"tcs_01M5KGJH4TS7KFM4MWAGT3S95K","modified_at":"2026-06-10T17:01:59.667484695Z","published_at":"2023-08-15T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-146","https://github.com/hwchase17/langchain/issues/5872","https://github.com/hwchase17/langchain/pull/6003","https://twitter.com/llm_sec/status/1668711587287375876","https://github.com/advisories/GHSA-92j5-3459-qgp4"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-146","url":"https://osv.dev/vulnerability/PYSEC-2023-146"}],"summary":"An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to execute arbitrary code via the from_math_prompt and from_colored_object_prompt functions."}