{"action":"Upgrade langchain to 0.0.233 or later.","affected":[{"fixed":"0.0.233","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-39659"],"ecosystem":"PyPI","epss":0.01534,"exploited":false,"fixed_versions":["0.0.233"],"ghsa_id":"GHSA-prgp-w7vf-ch62","id":"tcs_01M5KGJH99D75DBN0BWVVZDNVG","modified_at":"2026-06-10T17:02:00.020660387Z","published_at":"2023-08-15T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-147","https://github.com/langchain-ai/langchain/issues/7700","https://github.com/langchain-ai/langchain/pull/5640","https://github.com/advisories/GHSA-prgp-w7vf-ch62"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-147","url":"https://osv.dev/vulnerability/PYSEC-2023-147"}],"summary":"An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component."}