{"action":"Upgrade llama-index to 0.7.14 or later.","affected":[{"fixed":"0.7.14","introduced":"0"}],"component":"llama-index","cve_ids":["CVE-2023-39662"],"ecosystem":"PyPI","epss":0.01492,"exploited":false,"fixed_versions":["0.7.14"],"ghsa_id":"GHSA-2xxc-73fv-36f7","id":"tcs_01M5KGJHDSKZZP04X3VYZEB2C5","modified_at":"2026-06-10T17:01:55.576585358Z","published_at":"2023-08-15T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-148","https://github.com/jerryjliu/llama_index/issues/7054","https://github.com/advisories/GHSA-2xxc-73fv-36f7"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-148","url":"https://osv.dev/vulnerability/PYSEC-2023-148"}],"summary":"An issue in llama_index v.0.7.13 and before allows a remote attacker to execute arbitrary code via the `exec` parameter in PandasQueryEngine function."}