{"action":"Upgrade langchain to 0.0.171 or later.","affected":[{"fixed":"0.0.171","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-36281"],"ecosystem":"PyPI","epss":0.0344,"exploited":false,"fixed_versions":["0.0.171"],"ghsa_id":"GHSA-7gfq-f96f-g85j","id":"tcs_01M5KGJJAZDHAXAPPZJW6A8D7H","modified_at":"2026-06-10T17:02:00.098771930Z","published_at":"2023-08-22T19:16:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-151","https://github.com/hwchase17/langchain/issues/4394","https://aisec.today/LangChain-2e6244a313dd46139c5ef28cbcab9e55","https://github.com/advisories/GHSA-7gfq-f96f-g85j"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-151","url":"https://osv.dev/vulnerability/PYSEC-2023-151"}],"summary":"An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via the via the a json file to the load_prompt parameter."}