{"action":"Upgrade jupyter-server to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"}],"component":"jupyter-server","cve_ids":["CVE-2023-40170"],"ecosystem":"PyPI","epss":0.00623,"exploited":false,"fixed_versions":["2.7.2"],"ghsa_id":"GHSA-64x5-55rw-9974","id":"tcs_01M5KGJK7Q6D71RRSE35DP2R7Z","modified_at":"2023-11-08T04:13:19.479699Z","published_at":"2023-08-28T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-157","https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-64x5-55rw-9974","https://github.com/jupyter-server/jupyter_server/commit/87a4927272819f0b1cae1afa4c8c86ee2da002fd"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2023-157","url":"https://osv.dev/vulnerability/PYSEC-2023-157"}],"summary":"jupyter-server is the backend for Jupyter web applications. Improper cross-site credential checks on `/files/` URLs could allow exposure of certain file contents, or accessing files when opening untru"}