{"action":"Upgrade langchain to 0.0.308 or later.","affected":[{"fixed":"0.0.308","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-39631"],"ecosystem":"PyPI","epss":0.016,"exploited":false,"fixed_versions":["0.0.308"],"ghsa_id":"GHSA-f73w-4m7g-ch9x","id":"tcs_01M5KGJM9SP5VH0846JW31J6W9","modified_at":"2023-11-08T04:13:15.129905Z","published_at":"2023-09-01T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-162","https://github.com/pydata/numexpr/issues/442","https://github.com/langchain-ai/langchain/issues/8363","https://github.com/langchain-ai/langchain/pull/11302"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-162","url":"https://osv.dev/vulnerability/PYSEC-2023-162"}],"summary":"An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library."}