{"action":"Upgrade numexpr to 2.8.5 or later.","affected":[{"fixed":"2.8.5","introduced":"0"}],"component":"numexpr","cve_ids":["CVE-2023-39631"],"ecosystem":"PyPI","epss":0.016,"exploited":false,"fixed_versions":["2.8.5"],"ghsa_id":"GHSA-f73w-4m7g-ch9x","id":"tcs_01M5KGJMEFZQV3K94BP8NVJX1R","modified_at":"2026-06-10T17:02:26.302359325Z","published_at":"2023-09-01T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-163","https://github.com/pydata/numexpr/issues/442","https://github.com/langchain-ai/langchain/issues/8363","https://github.com/advisories/GHSA-f73w-4m7g-ch9x"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-163","url":"https://osv.dev/vulnerability/PYSEC-2023-163"}],"summary":"An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library."}