{"action":"Upgrade vyper to 0.3.10rc1 or later.","affected":[{"fixed":"0.3.10rc1","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2023-40015"],"ecosystem":"PyPI","epss":0.00492,"exploited":false,"fixed_versions":["0.3.10rc1"],"ghsa_id":"GHSA-g2xh-c426-v8mf","id":"tcs_01M5KGJN49AJ559RTHF5A45QN7","modified_at":"2023-11-08T04:13:16.353084Z","published_at":"2023-09-04T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-167","https://github.com/vyperlang/vyper/security/advisories/GHSA-g2xh-c426-v8mf"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2023-167","url":"https://osv.dev/vulnerability/PYSEC-2023-167"}],"summary":"Vyper is a Pythonic Smart Contract Language. For the following (probably non-exhaustive) list of expressions, the compiler evaluates the arguments from right to left instead of left to right. `unsafe_"}