{"action":"Upgrade gevent to 23.9.0 or later.","affected":[{"fixed":"23.9.0","introduced":"0"}],"component":"gevent","cve_ids":["CVE-2023-41419"],"ecosystem":"PyPI","epss":0.01793,"exploited":false,"fixed_versions":["23.9.0"],"ghsa_id":"GHSA-x7m3-jprg-wc5g","id":"tcs_01M5KGJPZ6GXPEDF908DQ374F3","modified_at":"2026-06-10T17:01:18.969238165Z","published_at":"2023-09-25T12:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-177","https://github.com/gevent/gevent/issues/1989","https://github.com/gevent/gevent/commit/2f53c851eaf926767fbac62385615efd4886221c","https://github.com/advisories/GHSA-x7m3-jprg-wc5g"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-177","url":"https://osv.dev/vulnerability/PYSEC-2023-177"}],"summary":"An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component."}