{"action":"Upgrade asyncssh to 2.14.1 or later.","affected":[{"fixed":"2.14.1","introduced":"0"}],"component":"asyncssh","cve_ids":["CVE-2023-46445"],"ecosystem":"PyPI","epss":0.00586,"exploited":false,"fixed_versions":["2.14.1"],"ghsa_id":"GHSA-cfc2-wr2v-gxm5","id":"tcs_01M5KGK1T7JGE3XWPBY3NR2R43","modified_at":"2023-11-17T17:41:55.151148Z","published_at":"2023-11-14T03:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-237","https://github.com/ronf/asyncssh/security/advisories/GHSA-cfc2-wr2v-gxm5"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"PYSEC-2023-237","url":"https://osv.dev/vulnerability/PYSEC-2023-237"}],"summary":"An issue in AsyncSSH v2.14.0 and earlier allows attackers to control the extension info message (RFC 8308) via a man-in-the-middle attack."}