{"action":"Upgrade crypto-js to 4.2.0 or later.","affected":[{"fixed":"4.2.0","introduced":"0"}],"component":"crypto-js","cve_ids":["CVE-2023-46233"],"ecosystem":"npm","epss":0.0064,"exploited":false,"fixed_versions":["4.2.0"],"ghsa_id":"GHSA-xwcq-pm8m-c4vf","id":"tcs_01M5KGK3TQCNX3XR034CTXYCX9","modified_at":"2026-09-10T03:49:58.831533491Z","published_at":"2023-10-25T21:15:52Z","references":["https://osv.dev/vulnerability/GHSA-xwcq-pm8m-c4vf","https://github.com/brix/crypto-js/security/advisories/GHSA-xwcq-pm8m-c4vf","https://nvd.nist.gov/vuln/detail/CVE-2023-46233","https://github.com/brix/crypto-js/commit/421dd538b2d34e7c24a5b72cc64dc2b9167db40a","https://github.com/brix/crypto-js","https://lists.debian.org/debian-lts-announce/2023/11/msg00025.html"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-xwcq-pm8m-c4vf","url":"https://osv.dev/vulnerability/GHSA-xwcq-pm8m-c4vf"}],"summary":"crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard"}