{"action":"Upgrade mechanize to 0.4.6 or later.","affected":[{"fixed":"0.4.6","introduced":"0"}],"component":"mechanize","cve_ids":["CVE-2021-32837"],"ecosystem":"PyPI","epss":0.28872,"exploited":false,"fixed_versions":["0.4.6"],"ghsa_id":"GHSA-g3pv-pj5f-3hfq","id":"tcs_01M5KGK4BPKAWBZ4JWVC9Z8Y26","modified_at":"2026-06-10T17:02:09.109644376Z","published_at":"2023-01-17T22:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-25","https://securitylab.github.com/advisories/GHSL-2021-108-python-mechanize-mechanize/","https://github.com/python-mechanize/mechanize/commit/dd05334448e9f39814bab044d2eaa5ef69b410d6","https://github.com/python-mechanize/mechanize/blob/3acb1836f3fd8edc5a758a417dd46b53832ae3b5/mechanize/_urllib2_fork.py#L878-L879","https://github.com/python-mechanize/mechanize/releases/tag/v0.4.6","https://github.com/advisories/GHSA-g3pv-pj5f-3hfq"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-25","url":"https://osv.dev/vulnerability/PYSEC-2023-25"}],"summary":"mechanize, a library for automatically interacting with HTTP web servers, contains a regular expression that is vulnerable to regular expression denial of service (ReDoS) prior to version 0.4.6. If a"}