{"action":"Upgrade sap-xssec to 4.1.0 or later.","affected":[{"fixed":"4.1.0","introduced":"0"}],"component":"sap-xssec","cve_ids":["CVE-2023-50423"],"ecosystem":"PyPI","epss":0.01109,"exploited":false,"fixed_versions":["4.1.0"],"ghsa_id":"GHSA-6mjg-37cp-42x5","id":"tcs_01M5KGK6N97T811S4NXYZRZZS4","modified_at":"2024-09-30T19:12:13.772998Z","published_at":"2023-12-12T02:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-261","https://me.sap.com/notes/3411067","https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html","https://pypi.org/project/sap-xssec/","https://blogs.sap.com/2023/12/12/unveiling-critical-security-updates-sap-btp-security-note-3411067/","https://github.com/SAP/cloud-pysec/security/advisories/GHSA-6mjg-37cp-42x5","https://github.com/SAP/cloud-pysec/"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-261","url":"https://osv.dev/vulnerability/PYSEC-2023-261"}],"summary":"SAP BTP Security Services Integration Library ([Python] sap-xssec) - versions < 4.1.0, allow under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attack"}