{"action":"Upgrade apache-airflow to 2.8.0 or later.","affected":[{"fixed":"2.8.0","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2023-50783"],"ecosystem":"PyPI","epss":0.0139,"exploited":false,"fixed_versions":["2.8.0"],"ghsa_id":"GHSA-5938-79hg-xh3q","id":"tcs_01M5KGK7E5A8WYB2ZCRZCYQF72","modified_at":"2026-06-10T17:00:25.082741220Z","published_at":"2023-12-21T10:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-267","https://github.com/apache/airflow/pull/33932","https://lists.apache.org/thread/rs7cr3yp726mb89s1m844hy9pq7frgcn","http://www.openwall.com/lists/oss-security/2023/12/21/4","https://github.com/advisories/GHSA-5938-79hg-xh3q"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2023-267","url":"https://osv.dev/vulnerability/PYSEC-2023-267"}],"summary":"Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable."}