{"action":"Upgrade apache-airflow to 3.1.1 or later.","affected":[{"fixed":"3.1.1","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2023-25693"],"ecosystem":"PyPI","epss":0.01895,"exploited":false,"fixed_versions":["3.1.1"],"ghsa_id":"GHSA-j69x-v4wc-3fpf","id":"tcs_01M5KGKEPD80BN5BNYF44JNQC0","modified_at":"2026-06-29T12:26:15.014279909Z","published_at":"2023-02-24T12:15:30.720Z","references":["https://osv.dev/vulnerability/PYSEC-2023-314","https://lists.apache.org/thread/79qn8g5xbq036f8crb115obvr22l52q4","https://github.com/apache/airflow/pull/29500"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2023-314","url":"https://osv.dev/vulnerability/PYSEC-2023-314"}],"summary":"Improper Input Validation vulnerability in the Apache Airflow Sqoop Provider."}