{"action":"Upgrade psiturk to 3.2.1 or later.","affected":[{"fixed":"3.2.1","introduced":"0"}],"component":"psiturk","cve_ids":["CVE-2021-4315"],"ecosystem":"PyPI","epss":0.00906,"exploited":false,"fixed_versions":["3.2.1"],"ghsa_id":"GHSA-9mq4-9556-6qxq","id":"tcs_01M5KGKHWM2N8JV7YN5VQT7Y0P","modified_at":"2026-06-10T17:01:43.719417107Z","published_at":"2023-01-28T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-43","https://github.com/NYUCCL/psiTurk/releases/tag/v3.2.1","https://vuldb.com/?ctiid.219676","https://vuldb.com/?id.219676","https://github.com/NYUCCL/psiTurk/commit/47787e15cecd66f2aa87687bf852ae0194a4335f","https://github.com/NYUCCL/psiTurk/pull/517","https://github.com/advisories/GHSA-9mq4-9556-6qxq"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-43","url":"https://osv.dev/vulnerability/PYSEC-2023-43"}],"summary":"A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mod"}