{"action":"Upgrade pyspark to 3.4.0 or later.","affected":[{"fixed":"3.4.0","introduced":"0"}],"component":"pyspark","cve_ids":["CVE-2023-22946"],"ecosystem":"PyPI","epss":0.01109,"exploited":false,"fixed_versions":["3.4.0"],"ghsa_id":"GHSA-329j-jfvr-rhr6","id":"tcs_01M5KGKJ18JWMH9JZ2NTRHPPPM","modified_at":"2026-06-10T17:01:37.151759446Z","published_at":"2023-04-17T08:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-44","https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv","https://github.com/advisories/GHSA-329j-jfvr-rhr6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-44","url":"https://osv.dev/vulnerability/PYSEC-2023-44"}],"summary":"In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitti"}