{"action":"Upgrade mage-ai to 0.8.72 or later.","affected":[{"fixed":"0.8.72","introduced":"0.8.34"}],"component":"mage-ai","cve_ids":["CVE-2023-31143"],"ecosystem":"PyPI","epss":0.00659,"exploited":false,"fixed_versions":["0.8.72"],"ghsa_id":"GHSA-c6mm-2g84-v4m7","id":"tcs_01M5KGKNKTHGK3KAN3J03FSBJP","modified_at":"2023-11-08T04:12:29.944518Z","published_at":"2023-05-09T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-64","https://github.com/mage-ai/mage-ai/commit/f63cd00f6a3be372397d37a4c9a49bfaf50d7650","https://github.com/mage-ai/mage-ai/security/advisories/GHSA-c6mm-2g84-v4m7"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-64","url":"https://osv.dev/vulnerability/PYSEC-2023-64"}],"summary":"mage-ai is an open-source data pipeline tool for transforming and integrating data. Those who use Mage starting in version 0.8.34 and prior to 0.8.72 with user authentication enabled may be affected b"}