{"action":"Upgrade requests to 2.31.0 or later.","affected":[{"fixed":"2.31.0","introduced":"2.3.0"}],"component":"requests","cve_ids":["CVE-2023-32681"],"ecosystem":"PyPI","epss":0.02974,"exploited":false,"fixed_versions":["2.31.0"],"ghsa_id":"GHSA-j8r2-6x86-q33q","id":"tcs_01M5KGKQBX0RA2E1AN6XPRH53W","modified_at":"2023-11-08T04:12:35.436175Z","published_at":"2023-05-26T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-74","https://github.com/psf/requests/security/advisories/GHSA-j8r2-6x86-q33q","https://github.com/psf/requests/releases/tag/v2.31.0","https://github.com/psf/requests/commit/74ea7cf7a6a27a4eeb2ae24e162bcc942a6706d5","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AW7HNFGYP44RT3DUDQXG2QT3OEV2PJ7Y/"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-74","url":"https://osv.dev/vulnerability/PYSEC-2023-74"}],"summary":"Requests is a HTTP library. Since Requests 2.3.0, Requests has been leaking Proxy-Authorization headers to destination servers when redirected to an HTTPS endpoint. This is a product of how we use `re"}