{"action":"Upgrade vyper to 0.3.8 or later.","affected":[{"fixed":"0.3.8","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2023-32059"],"ecosystem":"PyPI","epss":0.00725,"exploited":false,"fixed_versions":["0.3.8"],"ghsa_id":"GHSA-ph9x-4vc9-m39g","id":"tcs_01M5KGKR2A9V41TS6W59CBQQCW","modified_at":"2023-11-08T04:12:32.885897Z","published_at":"2023-05-11T22:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-79","https://github.com/vyperlang/vyper/commit/c3e68c302aa6e1429946473769dd1232145822ac","https://github.com/vyperlang/vyper/security/advisories/GHSA-ph9x-4vc9-m39g"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-79","url":"https://osv.dev/vulnerability/PYSEC-2023-79"}],"summary":"Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, internal calls with default arguments are compiled incorrectly. Depending on the number of argumen"}