{"action":"Upgrade sqlparse to 0.4.4 or later.","affected":[{"fixed":"0.4.4","introduced":"0.1.15"}],"component":"sqlparse","cve_ids":["CVE-2023-30608"],"ecosystem":"PyPI","epss":0.0098,"exploited":false,"fixed_versions":["0.4.4"],"ghsa_id":"GHSA-rrm6-wvj7-cwh2","id":"tcs_01M5KGKSG8ZWGERNKX116F11GT","modified_at":"2023-11-08T04:12:25.842993Z","published_at":"2023-04-18T22:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-87","https://github.com/andialbrecht/sqlparse/security/advisories/GHSA-rrm6-wvj7-cwh2","https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS","https://github.com/andialbrecht/sqlparse/commit/c457abd5f097dd13fb21543381e7cfafe7d31cfb","https://github.com/andialbrecht/sqlparse/commit/e75e35869473832a1eb67772b1adfee2db11b85a","https://lists.debian.org/debian-lts-announce/2023/05/msg00017.html"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-87","url":"https://osv.dev/vulnerability/PYSEC-2023-87"}],"summary":"sqlparse is a non-validating SQL parser module for Python. In affected versions the SQL parser contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). This is"}