{"action":"Upgrade langchain to 0.0.247 or later.","affected":[{"fixed":"0.0.247","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-36258"],"ecosystem":"PyPI","epss":0.01074,"exploited":false,"fixed_versions":["0.0.247"],"ghsa_id":"GHSA-2qmj-7962-cjq8","id":"tcs_01M5KGKVP26ECKN60WNG1M4TJB","modified_at":"2026-06-10T17:01:58.047656384Z","published_at":"2023-07-03T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-98","https://github.com/langchain-ai/langchain/issues/5872","https://github.com/advisories/GHSA-2qmj-7962-cjq8"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-98","url":"https://osv.dev/vulnerability/PYSEC-2023-98"}],"summary":"An issue in langchain v.0.0.199 allows an attacker to execute arbitrary code via the PALChain in the python exec method."}