{"action":"Upgrade pipreqs to 0.4.12 or later.","affected":[{"fixed":"0.4.12","introduced":"0.3.0"}],"component":"pipreqs","cve_ids":["CVE-2023-31543"],"ecosystem":"PyPI","epss":0.01187,"exploited":false,"fixed_versions":["0.4.12"],"ghsa_id":"GHSA-v4f4-23wc-99mh","id":"tcs_01M5KGKVTYVTAYNRJEPTS0CXPT","modified_at":"2026-06-10T17:02:29.025319375Z","published_at":"2023-06-30T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2023-99","https://github.com/bndr/pipreqs/pull/364","https://gist.github.com/adeadfed/ccc834440af354a5638f889bee34bafe","https://github.com/advisories/GHSA-v4f4-23wc-99mh"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2023-99","url":"https://osv.dev/vulnerability/PYSEC-2023-99"}],"summary":"A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server."}