{"action":"Upgrade django to 4.2.16 or later.","affected":[{"fixed":"4.2.16","introduced":"4.2"},{"fixed":"5.0.9","introduced":"5.0"},{"fixed":"5.1.1","introduced":"5.1"}],"component":"django","cve_ids":["CVE-2024-45230"],"ecosystem":"PyPI","epss":0.25773,"exploited":false,"fixed_versions":["5.1.1","5.0.9","4.2.16"],"ghsa_id":"GHSA-5hgc-2vfp-mqvc","id":"tcs_01M5KGKWKBK3ETG6E11BQ9D75S","modified_at":"2026-06-10T17:00:52.437805812Z","published_at":"2024-10-08T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-102","https://docs.djangoproject.com/en/dev/releases/security/","https://groups.google.com/forum/#%21forum/django-announce","https://www.djangoproject.com/weblog/2024/sep/03/security-releases/","https://github.com/advisories/GHSA-5hgc-2vfp-mqvc"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-102","url":"https://osv.dev/vulnerability/PYSEC-2024-102"}],"summary":"An issue was discovered in Django 5.1 before 5.1.1, 5.0 before 5.0.9, and 4.2 before 4.2.16. The urlize() and urlizetrunc() template filters are subject to a potential denial-of-service attack via ver"}