{"action":"Upgrade vyper to 0.4.0b1 or later.","affected":[{"fixed":"0.4.0b1","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2024-24559"],"ecosystem":"PyPI","epss":0.00255,"exploited":false,"fixed_versions":["0.4.0b1"],"ghsa_id":"GHSA-6845-xw22-ffxv","id":"tcs_01M5KGM4DPAH297DNYM3MD5NFN","modified_at":"2024-11-21T14:57:09.681968Z","published_at":"2024-02-05T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-147","https://github.com/vyperlang/vyper/security/advisories/GHSA-6845-xw22-ffxv","https://github.com/vyperlang/vyper/blob/c150fc49ee9375a930d177044559b83cb95f7963/vyper/ir/compile_ir.py#L585-L586"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-147","url":"https://osv.dev/vulnerability/PYSEC-2024-147"}],"summary":"Vyper is a Pythonic Smart Contract Language for the EVM. There is an error in the stack management when compiling the `IR` for `sha3_64`. Concretely, the `height` variable is miscalculated. The vulner"}