{"action":"Upgrade djoser to 2.3.0 or later.","affected":[{"fixed":"2.3.0","introduced":"0"}],"component":"djoser","cve_ids":["CVE-2024-21543"],"ecosystem":"PyPI","epss":0.00546,"exploited":false,"fixed_versions":["2.3.0"],"ghsa_id":"GHSA-v49p-m6gh-747c","id":"tcs_01M5KGM657ETVJB1QXFWH4EMZS","modified_at":"2026-06-10T17:01:12.156461162Z","published_at":"2024-12-13T05:15:07Z","references":["https://osv.dev/vulnerability/PYSEC-2024-158","https://github.com/sunscrapers/djoser/commit/d33c3993c0c735f23cbedc60fa59fce69354f19d","https://github.com/sunscrapers/djoser/issues/795","https://github.com/sunscrapers/djoser/pull/819","https://github.com/sunscrapers/djoser/releases/tag/2.3.0","https://security.snyk.io/vuln/SNYK-PYTHON-DJOSER-8366540","https://github.com/advisories/GHSA-v49p-m6gh-747c"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-158","url":"https://osv.dev/vulnerability/PYSEC-2024-158"}],"summary":"Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, gra"}