{"action":"Upgrade vyper to 0.4.0b1 or later.","affected":[{"fixed":"0.4.0b1","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2024-26149"],"ecosystem":"PyPI","epss":0.00547,"exploited":false,"fixed_versions":["0.4.0b1"],"ghsa_id":"GHSA-9p8r-4xp4-gw5w","id":"tcs_01M5KGM7JJ62CHFEDRW3WNVAYY","modified_at":"2026-06-10T17:14:18.967761542Z","published_at":"2024-02-26T20:19:05Z","references":["https://osv.dev/vulnerability/PYSEC-2024-164","https://github.com/vyperlang/vyper/security/advisories/GHSA-9p8r-4xp4-gw5w","https://github.com/advisories/GHSA-9p8r-4xp4-gw5w"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-164","url":"https://osv.dev/vulnerability/PYSEC-2024-164"}],"summary":"Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read posi"}