{"action":"Upgrade zenml to 0.56.2 or later.","affected":[{"fixed":"0.56.2","introduced":"0"}],"component":"zenml","cve_ids":["CVE-2024-2035"],"ecosystem":"PyPI","epss":0.00628,"exploited":false,"fixed_versions":["0.56.2"],"ghsa_id":"GHSA-9x88-4jg8-4vf7","id":"tcs_01M5KGM89RZJ0XN7KDAEKJRADD","modified_at":"2026-06-10T17:02:51.353388607Z","published_at":"2024-06-06T19:15:53Z","references":["https://osv.dev/vulnerability/PYSEC-2024-169","https://huntr.com/bounties/1cfc6493-082e-4229-9f2f-496801a6557c","https://github.com/zenml-io/zenml/commit/b95f083efffa56831cd41d8ed536aeb0b6038fa3","https://github.com/advisories/GHSA-9x88-4jg8-4vf7"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2024-169","url":"https://osv.dev/vulnerability/PYSEC-2024-169"}],"summary":"An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify t"}