{"action":"Upgrade langflow to 1.0.0a3 or later.","affected":[{"fixed":"1.0.0a3","introduced":"0"}],"component":"langflow","cve_ids":["CVE-2024-37014"],"ecosystem":"PyPI","epss":0.63674,"exploited":false,"fixed_versions":["1.0.0a3"],"ghsa_id":"GHSA-qg33-x2c5-6p44","id":"tcs_01M5KGM9R6SHRFVZ6WZ6ZBQM13","modified_at":"2026-06-10T17:02:02.798531622Z","published_at":"2024-06-10T20:15:15Z","references":["https://osv.dev/vulnerability/PYSEC-2024-177","https://github.com/langflow-ai/langflow/issues/1973","https://github.com/advisories/GHSA-qg33-x2c5-6p44"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2024-177","url":"https://osv.dev/vulnerability/PYSEC-2024-177"}],"summary":"Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the \"POST /api/v1/custom_component\" endpoint and provide a Python script."}