{"action":"Upgrade octoprint to 1.10.0 or later.","affected":[{"fixed":"1.10.0","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2024-28237"],"ecosystem":"PyPI","epss":0.00439,"exploited":false,"fixed_versions":["1.10.0"],"ghsa_id":"GHSA-x7mf-wrh9-r76c","id":"tcs_01M5KGMA2B8V0CGWE4H4G6CEZ2","modified_at":"2026-06-10T17:14:16.017469834Z","published_at":"2024-03-18T22:15:07Z","references":["https://osv.dev/vulnerability/PYSEC-2024-179","https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-x7mf-wrh9-r76c","https://github.com/OctoPrint/OctoPrint/commit/779894c1bc6478332d14bc9ed1006df1354eb517","https://github.com/advisories/GHSA-x7mf-wrh9-r76c"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"PYSEC-2024-179","url":"https://osv.dev/vulnerability/PYSEC-2024-179"}],"summary":"OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to configure or talk a vic"}