{"action":"Upgrade apache-airflow to 2.10.0 or later.","affected":[{"fixed":"2.10.0","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2024-41937"],"ecosystem":"PyPI","epss":0.0173,"exploited":false,"fixed_versions":["2.10.0"],"ghsa_id":"GHSA-w7cp-g8v7-r54m","id":"tcs_01M5KGMAJMJ1H63MNG7AHC51NJ","modified_at":"2026-06-10T17:00:25.148190953Z","published_at":"2024-08-21T16:15:08Z","references":["https://osv.dev/vulnerability/PYSEC-2024-181","https://github.com/apache/airflow/pull/40933","https://lists.apache.org/thread/lwlmgg6hqfmkpvw5py4w53hxyl37jl6d","http://www.openwall.com/lists/oss-security/2024/08/21/3","https://github.com/advisories/GHSA-w7cp-g8v7-r54m"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2024-181","url":"https://osv.dev/vulnerability/PYSEC-2024-181"}],"summary":"Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link."}