{"action":"Upgrade apache-airflow to 2.9.3 or later.","affected":[{"fixed":"2.9.3","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2024-39863"],"ecosystem":"PyPI","epss":0.00996,"exploited":false,"fixed_versions":["2.9.3"],"ghsa_id":"GHSA-j482-47xf-p25c","id":"tcs_01M5KGMC32DBBR7ZCJR48222RJ","modified_at":"2026-06-10T17:00:25.101034393Z","published_at":"2024-07-17T08:15:01Z","references":["https://osv.dev/vulnerability/PYSEC-2024-189","https://lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3","https://github.com/apache/airflow/pull/40475","http://www.openwall.com/lists/oss-security/2024/07/16/6","https://github.com/advisories/GHSA-j482-47xf-p25c"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"PYSEC-2024-189","url":"https://osv.dev/vulnerability/PYSEC-2024-189"}],"summary":"Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3"}