{"action":"Upgrade llama-index to 0.10.38 or later.","affected":[{"fixed":"0.10.38","introduced":"0"}],"component":"llama-index","cve_ids":["CVE-2024-45201"],"ecosystem":"PyPI","epss":0.00533,"exploited":false,"fixed_versions":["0.10.38"],"ghsa_id":"GHSA-fxc2-8m62-m85x","id":"tcs_01M5KGMCQ0Z7WDXX0H3H30DR27","modified_at":"2026-06-29T12:26:26.008969714Z","published_at":"2024-08-22T20:15:10Z","references":["https://osv.dev/vulnerability/PYSEC-2024-192","https://github.com/run-llama/llama_index/compare/v0.10.37...v0.10.38","https://github.com/run-llama/llama_index/pull/13523"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-192","url":"https://osv.dev/vulnerability/PYSEC-2024-192"}],"summary":"An issue was discovered in llama_index before 0.10.38. download/integration.py includes an exec call for import {cls_name}."}