{"action":"Upgrade zenml to 0.56.3 or later.","affected":[{"fixed":"0.56.3","introduced":"0"}],"component":"zenml","cve_ids":["CVE-2024-2213"],"ecosystem":"PyPI","epss":0.00243,"exploited":false,"fixed_versions":["0.56.3"],"ghsa_id":"GHSA-j527-v579-m98h","id":"tcs_01M5KGMCW24A68AMBP1N79C9NB","modified_at":"2026-06-10T17:02:41.351664244Z","published_at":"2024-06-06T19:15:53Z","references":["https://osv.dev/vulnerability/PYSEC-2024-193","https://huntr.com/bounties/8f5534ac-fd08-4b8b-8c2e-35949aa36e48","https://github.com/zenml-io/zenml/commit/58cb3d987372c91eb605853c35325701733337c2","https://github.com/advisories/GHSA-j527-v579-m98h"],"severity":{"label":"low","score":3.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-193","url":"https://osv.dev/vulnerability/PYSEC-2024-193"}],"summary":"An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account passw"}