{"action":"Upgrade gradio to 4.44.0 or later.","affected":[{"fixed":"4.44.0","introduced":"0"}],"component":"gradio","cve_ids":["CVE-2024-47166"],"ecosystem":"PyPI","epss":0.00436,"exploited":false,"fixed_versions":["4.44.0"],"ghsa_id":"GHSA-37qc-qgx6-9xjv","id":"tcs_01M5KGMDFQCD7ZVG9A6J3VBCQG","modified_at":"2025-01-19T16:57:03.769875Z","published_at":"2024-10-10T22:15:10Z","references":["https://osv.dev/vulnerability/PYSEC-2024-197","https://github.com/gradio-app/gradio/security/advisories/GHSA-37qc-qgx6-9xjv"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-197","url":"https://osv.dev/vulnerability/PYSEC-2024-197"}],"summary":"Gradio is an open-source Python package designed for quick prototyping. This vulnerability involves a **one-level read path traversal** in the `/custom_component` endpoint. Attackers can exploit this"}