{"action":"Upgrade jupyterhub to 4.1.6 or later.","affected":[{"fixed":"4.1.6","introduced":"0"}],"component":"jupyterhub","cve_ids":["CVE-2024-41942"],"ecosystem":"PyPI","epss":0.0059,"exploited":false,"fixed_versions":["4.1.6"],"ghsa_id":"GHSA-9x4q-3gxw-849f","id":"tcs_01M5KGMEH4NN24529REXTXWH2A","modified_at":"2025-01-19T16:57:10.916115Z","published_at":"2024-08-08T15:15:17Z","references":["https://osv.dev/vulnerability/PYSEC-2024-200","https://github.com/jupyterhub/jupyterhub/security/advisories/GHSA-9x4q-3gxw-849f","https://github.com/jupyterhub/jupyterhub/commit/99e2720b0fc626cbeeca3c6337f917fdacfaa428","https://github.com/jupyterhub/jupyterhub/commit/ff2db557a85b6980f90c3158634bf924063ab8ba"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"PYSEC-2024-200","url":"https://osv.dev/vulnerability/PYSEC-2024-200"}],"summary":"JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own"}