{"action":"Upgrade octoprint to 1.10.3 or later.","affected":[{"fixed":"1.10.3","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2024-49377"],"ecosystem":"PyPI","epss":0.00289,"exploited":false,"fixed_versions":["1.10.3"],"ghsa_id":"GHSA-xvxq-g8hw-fx4g","id":"tcs_01M5KGMEQEH5FJ1G3X0B8Q8DSE","modified_at":"2025-01-19T16:57:01.497087Z","published_at":"2024-11-05T19:15:05Z","references":["https://osv.dev/vulnerability/PYSEC-2024-201","https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-xvxq-g8hw-fx4g"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2024-201","url":"https://osv.dev/vulnerability/PYSEC-2024-201"}],"summary":"OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain reflected XSS vulnerabilities in the login dialog and the standalone a"}