{"action":"Upgrade octoprint to 1.10.3 or later.","affected":[{"fixed":"1.10.3","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2024-51493"],"ecosystem":"PyPI","epss":0.00281,"exploited":false,"fixed_versions":["1.10.3"],"ghsa_id":"GHSA-cc6x-8cc7-9953","id":"tcs_01M5KGMEVZ244PKCKP65VGBEJH","modified_at":"2025-01-19T16:56:59.219222Z","published_at":"2024-11-05T19:15:07Z","references":["https://osv.dev/vulnerability/PYSEC-2024-202","https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-cc6x-8cc7-9953"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2024-202","url":"https://osv.dev/vulnerability/PYSEC-2024-202"}],"summary":"OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain a vulnerability that allows an attacker that has gained temporary cont"}