{"action":"Upgrade vyper to 0.4.0 or later.","affected":[{"fixed":"0.4.0","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2024-32646"],"ecosystem":"PyPI","epss":0.00455,"exploited":false,"fixed_versions":["0.4.0"],"ghsa_id":"GHSA-r56x-j438-vw5m","id":"tcs_01M5KGMFMRE8RMWTYG1QE6W0DG","modified_at":"2026-06-10T17:14:16.953105766Z","published_at":"2024-04-25T18:15:08Z","references":["https://osv.dev/vulnerability/PYSEC-2024-207","https://github.com/vyperlang/vyper/security/advisories/GHSA-r56x-j438-vw5m","https://github.com/advisories/GHSA-r56x-j438-vw5m"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-207","url":"https://osv.dev/vulnerability/PYSEC-2024-207"}],"summary":"Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. In versions 0.3.10 and prior, using the `slice` builtin can result in a double eval vulnerability when the buffer argument"}