{"action":"Upgrade vyper to 0.4.0 or later.","affected":[{"fixed":"0.4.0","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2024-32649"],"ecosystem":"PyPI","epss":0.00455,"exploited":false,"fixed_versions":["0.4.0"],"ghsa_id":"GHSA-5jrj-52x8-m64h","id":"tcs_01M5KGMFYF73CXVESV1EDRN2DD","modified_at":"2026-06-10T17:14:19.150031848Z","published_at":"2024-04-25T18:15:09Z","references":["https://osv.dev/vulnerability/PYSEC-2024-209","https://github.com/vyperlang/vyper/security/advisories/GHSA-5jrj-52x8-m64h","https://github.com/advisories/GHSA-5jrj-52x8-m64h"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-209","url":"https://osv.dev/vulnerability/PYSEC-2024-209"}],"summary":"Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. In versions 0.3.10 and prior, using the `sqrt` builtin can result in double eval vulnerability when the argument has side-"}