{"action":"Upgrade gradio to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"gradio","cve_ids":["CVE-2024-47165"],"ecosystem":"PyPI","epss":0.00298,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-89v2-pqfv-c5r9","id":"tcs_01M5KGMGV45CV2NK8ERW6Q0FZM","modified_at":"2025-01-19T22:56:52.587676Z","published_at":"2024-10-10T22:15:10Z","references":["https://osv.dev/vulnerability/PYSEC-2024-214","https://github.com/gradio-app/gradio/security/advisories/GHSA-89v2-pqfv-c5r9"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"PYSEC-2024-214","url":"https://osv.dev/vulnerability/PYSEC-2024-214"}],"summary":"Gradio is an open-source Python package designed for quick prototyping. This vulnerability relates to **CORS origin validation accepting a null origin**. When a Gradio server is deployed locally, the"}