{"action":"Upgrade gradio to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"gradio","cve_ids":["CVE-2024-47870"],"ecosystem":"PyPI","epss":0.00372,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-xh2x-3mrm-fwqm","id":"tcs_01M5KGMHV55ETGG76CGJXPJCD8","modified_at":"2025-01-19T22:56:53.228101Z","published_at":"2024-10-10T23:15:03Z","references":["https://osv.dev/vulnerability/PYSEC-2024-218","https://github.com/gradio-app/gradio/security/advisories/GHSA-xh2x-3mrm-fwqm"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"PYSEC-2024-218","url":"https://osv.dev/vulnerability/PYSEC-2024-218"}],"summary":"Gradio is an open-source Python package designed for quick prototyping. This vulnerability involves a **race condition** in the `update_root_in_config` function, allowing an attacker to modify the `ro"}