{"action":"Upgrade gradio to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"gradio","cve_ids":["CVE-2024-47872"],"ecosystem":"PyPI","epss":0.00277,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-gvv6-33j7-884g","id":"tcs_01M5KGMJ8SPSKFGPYW1RK9AXPT","modified_at":"2025-01-19T22:56:51.887142Z","published_at":"2024-10-10T23:15:03Z","references":["https://osv.dev/vulnerability/PYSEC-2024-220","https://github.com/gradio-app/gradio/security/advisories/GHSA-gvv6-33j7-884g"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"PYSEC-2024-220","url":"https://osv.dev/vulnerability/PYSEC-2024-220"}],"summary":"Gradio is an open-source Python package designed for quick prototyping. This vulnerability involves **Cross-Site Scripting (XSS)** on any Gradio server that allows file uploads. Authenticated users ca"}